View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000909Sphinxgeneralpublic2011-08-26 13:352012-11-29 19:14
Reporterbarryhunter 
Assigned Toshodan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.1-beta 
Target VersionFixed in Version 
Summary0000909: Field End Modifier needs a space after it
DescriptionSee
http://sphinxsearch.com/forum/view.html?id=8124 [^]
and
http://sphinxsearch.com/forum/view.html?id=8166 [^]

Seems, the field end modifer becomes ineffective if followed by a quote or a bracket.

Adding a space fixes it.
Steps To ReproduceRun a query like

"^After the harvest$"

functions the same as

"^After the harvest"


One way to workaround it is to do

"^After the harvest$ "
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002717)
barryhunter (reporter)
2012-03-26 00:38

Another report of this issue
http://stackoverflow.com/questions/9856846/sphinx-field-start-and-field-end-extended2-search-not-working [^]
(0002718)
iparker (reporter)
2012-03-26 13:33

I am experiencing this issue as well. The severity of this issue needs to be updated to major from minor so that it can get more attention
(0002719)
barryhunter (reporter)
2012-03-26 13:50

I think I only put minor, as its fairly easy to workaround. just annoying.


$query = preg_replace('/\b$(["\)])/','\$ $1',$query);
(0002720)
shodan (administrator)
2012-03-27 03:02

Should be fixed in rel20/ branch, r3166.
(0003620)
barryhunter (reporter)
2012-11-29 17:39

This still seems to be broken

Server version: 2.1.1-dev (r3548)

<SNIP>

mysql> select title from sample8 where match('@title "^after the harvest$"');
Empty set (0.00 sec)

mysql> select title from sample8 where match('@title "^after the harvest$ "');
Empty set (0.00 sec)

mysql> select title from sample8 where match('@title "^after the harvest" harvest$');
Empty set (0.05 sec)

mysql> select title from sample8 where match('@title "^after the harvest" harvest$ ');
Empty set (0.06 sec)

mysql> select title from sample8 where match('@title "^after the harvest"');
+-------------------------------------------+
| title |
+-------------------------------------------+
| After the harvest |
| After the harvest |
| After the harvest, near Falconers Farm |
| After the harvest |
| After the harvest |
| After the harvest, Far Gearstones |
| After the harvest |
| After the Harvest |
| After the harvest |
| After the Harvest |
<SNIP>


Also tried:

2.0.4-release is also broken. Adding a space does NOT fix it.
2.1.1-dev (r3490).
2.0.6-dev (rel20-r3454)
2.0.7-dev (rel20-r3538)
2.1.1-dev (r3548)

All of them dont work. The only complex the index used on all these tests was built with 2.0.1-beta. I will retry building a small test index.
(0003621)
barryhunter (reporter)
2012-11-29 17:47

Actually building a test index...

Server version: 2.1.1-dev (r3548)
mysql> select title from testharvest where match('@title "^after the harvest$"');
+--------------------+
| title |
+--------------------+
| After the harvest |
| After the Harvest |
| After the harvest |
| After the harvest |
| After the harvest |
<SNIP>!


mysql> select title from testharvest where match('@title "^after the harvest "');
+-------------------------------------------------------+
| title |
+-------------------------------------------------------+
| After the Harvest, West Charleton |
| After the harvest |
| After the Harvest |
| After the harvest - fields between Dean and Sparsholt |
| After the Harvest, Norfolk |
| After the harvest |
| After the harvest, Smeatonwood Farm |
| After the harvest |
| After the harvest |
| After the harvest, Pound Lane |
<SNIP



Also tried
Server version: 2.0.7-dev (rel20-r3538)
having built a new index. It works!


And, tried 2.0.6-dev (rel20-r3454) works fine too.


So false alarm. It was because using a broken index generated with 2.0.1-beta! Generating a new index works fine. Panic over.
(0003622)
barryhunter (reporter)
2012-11-29 17:48

Sorry, seems I can reopen a ticket, but not close it again :(
(0003623)
klirichek (manager)
2012-11-29 19:14

> Sorry, seems I can reopen a ticket, but not close it again :(

Let me help you :)

- Issue History
Date Modified Username Field Change
2011-08-26 13:35 barryhunter New Issue
2012-03-26 00:38 barryhunter Note Added: 0002717
2012-03-26 13:33 iparker Note Added: 0002718
2012-03-26 13:50 barryhunter Note Added: 0002719
2012-03-27 03:02 shodan Note Added: 0002720
2012-03-27 03:02 shodan Status new => resolved
2012-03-27 03:02 shodan Fixed in Version => 2.0.5-release
2012-03-27 03:02 shodan Resolution open => fixed
2012-03-27 03:02 shodan Assigned To => shodan
2012-06-03 19:30 shodan Status resolved => closed
2012-06-03 19:30 shodan Fixed in Version 2.0.5-release =>
2012-11-29 17:39 barryhunter Note Added: 0003620
2012-11-29 17:39 barryhunter Status closed => feedback
2012-11-29 17:39 barryhunter Resolution fixed => reopened
2012-11-29 17:47 barryhunter Note Added: 0003621
2012-11-29 17:47 barryhunter Status feedback => assigned
2012-11-29 17:48 barryhunter Note Added: 0003622
2012-11-29 19:14 klirichek Note Added: 0003623
2012-11-29 19:14 klirichek Status assigned => closed
2012-11-29 19:14 klirichek Resolution reopened => fixed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker